Инфраструктуры открытых ключей.

Литература.

1. Балакирский В.Б, Безопасность электронных платежей. Защита информации, Конфидент, № 5, 1996.

2. Бернет С., Пэйн С, Криптография. Официальное руководство RSA Security, М.: Бином-Пресс, 2002.

3. Бруно Л, Certificate Authorities: Кому Вы доверяете?, Data Communications (Russian edition). № 3, 1998.

4. Вьюкова Н, Сервер аутентификации Kerberos,

5. Галатенко В.А, Информационная безопасность. Обзор основных положений, Jet Info. № 1-3, 1996.

6. Галатенко В.А, Стандарты в области безопасности распределенных систем, Jet Info, № 5, 1999.

7. Галатенко В.А, Основы информационной безопасности, М.: ИНТУИТ.РУ "Интернет-университет информационных технологий", 2003.

8. Галатенко В.А, Стандарты информационной безопасности, М.: ИНТУИТ.РУ "Интернет-университет Информационных технологий", 2004.

9. Горбатов В.С., Полянская О.Ю, Доверенные центры как звено системы обеспечения безопасности корпоративных информационных ресурсов, Информационный бюллетень Jet Info, № 11 (78), 1999.

10. Горбатов В.С., Полянская О.Ю, Основы технологии PKI, М.: Горячая линия - Телеком, 2003.

11. Горбатов В.С., Полянская О.Ю, Программная поддержка инфраструктуры с открытыми ключами, Безопасность информационных технологий, Вып. 2, МИФИ, 2001.

12. , ГОСТ 34.003-90,

13. , ГОСТ 28147-89,

14. , ГОСТ Р 34.10-94,

15. , ГОСТ Р 34.11-94,

16. , ГОСТ Р 34.10-2001,

17. Евдокимов Н.А, Аутсорсинг и инсорсинг как инструменты управления затратами, Сетевой электронный научный журнал "Системотехника", № 2, 2004.

18. , Закон РФ "Об электронной цифровой подписи",

19. Запечников С.В., Милославская Н.Г., Толстой А.И, Основы построения виртуальных частных сетей. М.: Горячая линия - Телеком, 2003,

20. Кадощук И, Как нам организовать PKI, Сетевой журнал, № 9, 2000.

21. Карве А, Защищенный обмен сообщениями, LAN / Журнал сетевых решений, № 12, 1998.

22. Карпов А Г, Удостоверяющий центр в системе электронного документооборота. Опыт построения открытых систем,

23. , Криптографический словарь (версия 2002.4),

24. Лукацкий А.В, Как обеспечить подлинность электронных документов,

25. Мэтью С, Инфраструктура открытых ключей: состояние и перспективы, Сетевой журнал, № 9, 2000.

26. Никонова Е., Смирнов В., Копылов Д, Некоторые технологические аспекты реализации закона об ЭЦП, PC Week, № 15, 23 апреля, 2002.

27. , Политика применения сертификатов ЗАО "Цифровая подпись",

28. Полянская О.Ю, Проблемы и риски в работе удостоверяющих центров,

29. Полянская О.Ю, Стандарты и спецификации в области инфраструктур открытых ключей. Безопасность информационных технологий, Вып. 1, М.: МИФИ, 2003.

30. Полянская О.Ю, Проблемы секретности и ответственности в системах PKI, Сборник научных трудов ХI Всероссийской научной конференции "Проблемы информационной безопасности в системе высшей школы", МИФИ, 2004.

31. Полянская О.Ю, Методы распространения информации в инфраструктурах открытых ключей, Безопасность информационных технологий, Вып. 4, М.: МИФИ, 2004.

32. Полянская О.Ю, Модели доверия в инфраструктурах открытых ключей. Сборник научных трудов ХII Всероссийской научной конференции "Проблемы информационной безопасности в системе высшей школы", МИФИ, 2005.

33. Полянская О.Ю, Сервисы, базирующиеся на инфраструктурах открытых ключей, Тезисы ХIV Общероссийской научно-технической конференции "Методы и технические средства обеспечения безопасности информации", Санкт-Петербург, 4-6 октября, 2005.

34. Полянская О.Ю, Технология PKI как основа формирования безопасной среды ведения бизнеса. Сборник научных трудов ХIII Всероссийской научной конференции "Проблемы информационной безопасности в системе высшей школы", МИФИ, 2006.

35. Полянская О.Ю, Современные бизнес-модели и решения развертывания PKI. Сборник научных трудов Всероссийской научно-технической конференции студентов, аспирантов и молодых ученых "Научная сессия ТУСУР-2006", Томск, ТУСУР, 4-7 мая, 2006.

36. Рапоза Д, Незнакомая PKI, PC Week/RE, январь 2001.

37. Семенов Г, Не только шифрование, или Обзор криптотехнологий, Jet Infosystems, № 3 (94), 2001.

38. Симонович П.С, Регулирование электронной цифровой подписи нормами права: международный опыт, Журнал российского права, № 3, 2002.

39. Харли Х, Конфиденциальность сообщений: будь начеку, LАN/Журнал сетевых решений, № 7-8,1999.

40. Циммерман Ф.Р, PGP: концепция безопасности и уязвимые места, Журнал "Компьютерра", № 48, 1997.

41. Шабат В, Каталоги LDAP и метакаталоги, Открытые системы, № 5, 2002.

42. Шабат В, Стратегический взгляд на Identity Management, CIO (Директор ИС), № 1, 2003.

43. Adams C., Lloyd S, Public-Key Certificates and Certification,

44. Adams C., Lloyd S, Understanding PKI. Concepts, Standards and Deployment Consideration. Second Edition, Addison-Wesley, 2003.

45. Adams C., Zuccherato R, A General, Flexible Approach to Certificate Revocation,

46. , Advances and Remaining Challenges to Adoption of Public Key Infrastructure Technology, U.S. General Accounting Office, GAO-01-277, February, 2001.

47. , AES Algorithm (Rijndael) Information,

48. , Architecture for Public-Key Infrastructure (APKI), Open Group Guide, G801, The Open Group, 1998.

49. Aura T., Ellison C, Privacy and Accountability in Certification Systems, Helsinki University of Technology, Laboratory for Theoretical Computer Science, Research Report, April 2000.

50. Bobbit M, PKI Policy Pitfalls, Information Security Magazine, July 2001.

51. Burr. W., Dodson D., Nazario N., Polk W T, Minimum Interoperability Specification for PKI, Components, Version 1, 1997, NIST SP 800-15.

52. , CCITT (International Telegraph and Telephone Consultative Committee). Recommendation X.208: Specification of Abstract Syntax Notation One (ASN.1), Geneva, 1988.

53. , CCITT. Recommendation X.209: Specification of Basic Encoding Rules for Abstract Syntax Notation One (ASN.1), Geneva, 1988.

54. , CCITT Recommendation X.500: The Directory, Geneva, 1993.

55. , CCITT. Recommendation X.501: The Directory - Models, Geneva, 1988.

56. , CCITT. Recommendation X.800: Security Architecture for Open Systems Interconnection for CCITT Applications, Geneva, 1991.

57. Chadwick D.W., Otenko A., Ball E, Implementing Role Based Access Controls Using X.509 Attribute Certificates,

58. Chadwick D.W., Otenko A., Hunter D., Leoni C, Privilege Management for E-construction,

59. , Common Criteria for Information Technology. Security Evaluation, Part 3: Security Assurance Requirements. January 2004. Version 2.2.

60. Cooper D.A., Polk W.T, NIST Recommendation for X.509 Path Validation Version 0.5, 2004.

61. , Current Methods of Authentication,

62. , Delta CRLs,

63. Diffie W., Hellman M.E, New Directions In Cryptography,

64. Dittrich D, Network "sniffers" and You,

65. Ellison C., Schneier B, Ten Risks of PKI: What You're not Being Told about Public Key Infrastructure, Computer Security Journal, vol. XVI, number 1, 2000.

66. , Extensible Markup Language (XML) 1.0 (Third Edition),

67. Hallam-Baker P., Ford W, Internet X.509 Public Key Infrastructure. Enhanced CRL distribution options, Internet Draft, PKIX Working Group, August 1998.

68. Hellberg S, SWEDAC-EID-SAT: Test specification of EID Cards and certificates,

69. Hesse P.M., Lemire D.P, Managing Interoperability in Non-Hierarchical Public Key In-frastructures,

70. Housley R., Polk W. T, Planning for PKI: Best practices for PKI Deployment, Wiley &Sons, 2001.

71. , Integration of DCE with a Public Key Infrastructure,

72. , Introduction to Security Overview. Authentication and Identification Methods,

73. , Introduction to Single Sign-On, The Open Group,

74. , ISO/IEC 8824 Object Identifiers (OIDs),

75. , ISO/IEC JT1/SC27 WD 14516-1, Guidelines for the use and management of Trusted Third Party services - Part 1:General Overview, 1995.11.

76. , ISO/IEC JT1/SC27 WD 14516-2, Guidelines for the use and management of Trusted Third Party services - Part 2: Technical aspects, 21.06.1996.

77. , ITU-T (International Telecommunications Union) Recommendation X.509: Information Technology - Open Systems Interconnection -The Directory: Authentication Framework, 1997.

78. , ITU-T Recommendation X.509, "Information Technology - Open Systems Interconnection - The Directory: Public Key and Attribute Certificate Frameworks", June 2000.

79. Jarupunphol P., Mitchell C, PKI implementation issues in B2B e-commerce EICAR Conference Best Paper Proceedings, 2003.

80. Johner H., Fujiwara S., Sm Yeung A., Stephanou A. W, Deploying a Public Key Infrastructure I, nternational Technical Support Organization, SG24-5512-00, February 2000.

81. , Kerberos: The Network Authentication Protocol,

82. Kiran S., Lareau P., Lloyd S, PKI Basics - A Technical Introduction, A PKI Forum Note, November 2002.

83. Kocher P.A, Quick Introduction to Certificate Revocation Trees (CRTs),

84. Kuhn D.R., Hu Vincent C., Polk W.T, Chang Shu-Jen, Introduction to Public Key Technology and the Federal PKI Infrastructure, National Institute of Standards and Technology, February, 2001.

85. Lamport L, Password Authentication with Insecure Communication, Coomunications of the ACM, vol. 24, no. 11, 1981, p. 770-772.

86. Lareau P, PKI Basics - A Business Perspective, A PKI Forum Note, April 2002, www.pkiforum.org/resourcees.html.

87. , LDAP Duplication/Replication/Update Protocols (ldup),

88. Linn J., Branchaud M, An Examination of Asserted PKI Issues and Proposed Alternatives,

89. Lloyd S, Understanding Certification Path Construction, A PKI Forum White Paper, September 2002.

90. Lloyd S, Paving the Road to PKI Interoperability,

91. Malpani A., Hoffman P., Housley R, Simple Certificate Validation Protocol (SCVP) Internet Draft November 2000,

92. , Minimum Interoperability Specification for PKI. Components, Version 2 - Second DRAFT, 2000. NIST PKI Project Team.

93. Needham R. Schroeder M, Using Encryption for Authenticating in Large Networks of Computers, Coomunications of the ACM, vol. 21, no. 12, 1978, p. 995-999.

94. , OASIS PKI Resources,

95. , OASIS Security Services (Security Assertion Markup Language - SAML) TC,

96. Olnes J., Verdier M., Ganivet N., Maillot D., Skretting J, Public Key Infrastructure and Certification Policy for Interdomain Management,

97. Perlman Radia, An Overview of PKI Trust Models,

98. , PGP User's Guide, Volume I: Essential Topics,

99. , PKI Interoperability Framework. PKI Forum White Paper,

100. Polk W.T., Hastings N.E., Malpani A, Public Key Infrastructures that Satisfy Security Goals,

101. Polk W.T., Hastings N.E, Bridge Certification Authorities: Connecting B2B Public Key Infrastructures, NIST,

102. , Public-Key Cryptography Standards, RSA Laboratories,

103. , Public Key Infrastructure. Request For Proposal. Object Management Group Document: ec/99-01-15,

104. , Public Key Infrastructure Standards,

105. Raina K, PKI Security Solutions for Enterprise: Solving HIPAA, E-Paper Act, and Other Compliance Issues, Wiley Publishing, Inc., 2003.

106. Reese A, The Architecture of Privacy, 2004.

107. , Request for Proposals for Certification Authority and Public Key Infrastructure Services, Office of the Secretary of Kansas State. Draft copy, 2001.

108. , Secure Network Time Protocol (stime),

109. , Secure Socket Layer (SSL) 3.0 Specification,

110. , Securities Industry Root. Certificate Authority (SIRCA),

111. , Security Assertion Markup Language (SAML),

112. , Security Service API: Cryptographic API Recommendation Second Edition, NSA Cross Organization CAPI Team July 1, 1996.

113. , SET Secure Electronic Transaction Specification. Book 1: Business Description, May 31, 1997.

114. , SET Secure Electronic Transaction Specification. Book 2: Programmer's Guide,

115. , SET Secure Electronic Transaction. Specification. Book 3: Formal Protocol Definition, May 31, 1997.

116. Slagell A.J, Bonilla R, PKI Scalability Issues,

117. , Standard for Entity Authentication Using Public Key Cryptography, FIPS 196 - Federal Information Processing Standard Publication 196, 1997.

118. Stapleton J, CA Trust, A PKI Forum Note, July 2001.

119. , Synopsis of PKI and Related Standards, The Center For Information Technology Stan-dards, 2000.

120. , Time Signing, Symmetricom Trusted Time,

121. Turnbull J, Cross-Certification and PKI Policy Networking August 2000 Version: 1.0,

122. , Understanding Public Key Infrastructure (PKI), Technology White Paper, PKI WP 0999, RSA Security Inc., 1999.

123. , What Are CA Certificates?,

124. , What is meant by trust?,

125. , WHAT IS SESAME?,

126. , X.500: Directory Access Protocol (DAP),

127. , X.500 Directories Part 2-Core Directory Information Tree and Schema Guideline,

128. , X.509 Certificate Policy. for the. E-Governance Certification Authorities, Version 1.3 9 November 2005.

129. , XML Key Management Specification (XKMS 2.0),

130. , RFC 822 Standard for the format of ARPA Internet text messages,

131. , RFC 959 File Transfer Protocol,

132. , RFC 1034 Domain names - concepts and facilities,

133. , RFC 1035 Domain names - implementation and specification,

134. , RFC 1305 Network Time Protocol (Version 3) Specification, Implementation and Analysis,

135. , RFC 1510 The Kerberos Network Authentication Service (V5),

136. , RFC 1760 The S/Key One-Time Password System,

137. , RFC 1991 PGP Message Exchange Formats,

138. , RFC 2015 PGP MIME Security with Pretty Good Privacy,

139. , RFC 2025 Simple Public Key GSS-API Mechanism (SPKM),

140. , RFC 2068 Hypertext Transfer Protocol - HTTP/1.1,

141. , RFC 2116 X.500 Implementations Catalog-96,

142. , RFC 2246 The TLS Protocol Version 1.0,

143. , RFC 2401 Security Architecture for the Internet Protocol,

144. , RFC 2402 IP Authentication Header,

145. , RFC 2406 IP Encapsulating Security Payload (ESP),

146. , RFC 2408 Internet Security Association and Key Management Protocol,

147. , RFC 2409 The Internet Key Exchange (IKE),

148. , RFC 2412 The OAKLEY Key Determination Protocol,

149. , RFC 2440 Open PGP Message Format,

150. , RFC 2510 Certificate Management Protocols (CMP),

151. , RFC2511 Certificate Request Protocol,

152. , RFC2527 Certificate Policy and Certification Practices Framework,

153. , RFC 2538 Storing Certificates in the Domain Name System (DNS),

154. , RFC2559 LDAP V2 Operational Protocols,

155. , RFC2560 Online Certificate Status Protocol (OCSP),

156. , RFC2585 HTTP/FTP Operations,

157. , RFC2587 LDAP V2 Schema,

158. , RFC 2632 S/MIME Version 3 Certificate Handling,

159. , RFC 2633 S/MIME Version 3 Message Specification,

160. , RFC2797 Certificate Management Messages over CMS (CMC),

161. , RFC 2849 The LDAP Data Interchange Format (LDIF),

162. , RFC2875 Diffie-Hellman Proof-of-Possession (POP) Algorithms,

163. , RFC 3029 Data Validation and Certification Server Protocols,

164. , RFC 3039 Qualified Certificates Profile,

165. , RFC 3161 Time-Stamp Protocol (TSP),

166. , RFC 3279 Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) Profile,

167. , RFC 3280 Certificate & CRL Profile,

168. , RFC 3281 An Internet Attribute Certificate Profile for Authorization,

169. , RFC 2311 S/MIME Version 2 Message Specification,

170. , RFC 2312 S/MIMEv2 Certificate Handling,

171. , RFC 2630 Cryptographic Message Syntax (CMS),

172. , RFC 2632 S/MIME V3 Certificate Handling,

173. , RFC 2633 S/MIME V3 Message Specification,

174. , RFC 2634 Enhanced Security Services for S/MIME,

175. , RFC 2692 SPKI Requirements,

176. , RFC 2785 Methods for Avoiding the "Small-Subgroup" Attacks on the Diffie-Hellman Key Agreement Method for S/MIME,

177. , RFC 2246 TLS Protocol Version 1.0,

178. , RFC 2659 Security Extensions For HTML,

179. , RFC 2660 The Secure HyperText Transfer Protocol,

180. , RFC 2817 Upgrading to TLS Within HTTP,

181. , RFC 2818 HTTP Over TLS,

182. , RFC 2401 Security Architecture for the Internet Protocol,

183. , RFC 2402 IP Authentication Header,

184. , RFC 2406 IP Encapsulating Security Payload (ESP),

185. , RFC 2408 Internet Security Association and Key Management Protocol (ISAKMP),

186. , RFC 2137 Secure Domain Name System Dynamic Update,

187. , RFC 2535 Domain Name System Security Extensions,

188. , RFC 2536 DSA KEYs and SIGs in the Domain Name System,

189. , RFC 2537 RSA/MD5 KEYs and SIGs in the Domain Name System,

190. , RFC 2538 Storing Certificates in the Domain Name System,

191. , RFC 2539 Storage of Diffie-Hellman Keys in the Domain Name System,

192. , RFC 2540 Detached Domain Name System Information,

193. , RFC 2541 DNS Security Operational Considerations,

194. , PKCS#1 RSA Cryptography,

195. , PKCS #3 Diffie-Hellman Key Agreement,

196. , PKCS #5 Password-Based Cryptography,

197. , PKCS #6 Extended-Certificate Syntax,

198. , PKCS#7 Cryptographic Message Syntax,

199. , PKCS #8 Private-Key Information Syntax,

200. , PKCS #9 Selected Attribute Types,

201. , PKCS#10 Certification Request Syntax,

202. , PKCS#11 Cryptographic Token Interface (Cryptoki),

203. , PKCS #12 Personal Information Exchange Syntax,

204. , PKCS #13 Elliptic Curve Cryptography,

205. , PKCS #15 Cryptographic Token Information Format,

206. , Federal Public Key Infrastructure (PKI),

207. , Yahoo! Privacy Center,

208. , SearchSecurity.com,

209. , Connect! Мир связи,

210. , Information Assurance Consulting Services,

211. , The independent european association for e-business,

212. , Открытая база знаний по информационной безопасности,

213. , КриптоПро,

214. , Entrust,

215. , ИД Finestreet,

216. , oszone.net,

217. , Компания Демос,

218. , The International PGP Home Page,

219. , The PKI page,

220. , VeriSign,