Инфраструктуры открытых ключей.

Стандарты в области PKI.

Стандарты играют существенную роль в развертывании и использовании PKI. Стандартизация в этой сфере позволяет разным приложениям взаимодействовать между собой с использованием единой PKI [219]. Стандарты в области PKI можно разбить на четыре группы, каждая из которых относится к определенному технологическому сегменту, необходимому для создания PKI.

К первой группе (см. табл. 15.1) можно отнести стандарты серии X, подготовленные Международным Союзом по телекоммуникациям - ITU (International Telecommunications Union), и стандарты Международной организации стандартизации - ISO (International Organization for Standardization), относящиеся к PKI [10]. Они признаны в международном масштабе, содержат описания концепций, моделей и сервиса каталога (X.500) и формализуют процедуру аутентификации (X.509). Стандарт X.509 первоначально предназначался для спецификации аутентификации при использовании в составе сервисов каталога X.500. С течением времени X.509 претерпел ряд изменений, и его последняя (третья) версия была стандартизована группой инженерной поддержки Интернета - Internet Engineering Task Force (IETF). Документ X.509 регулирует хранение информации в каталоге и получение данных аутентификации. Он характеризует криптосистему с открытым ключом как метод сильной аутентификации, который базируется на создании, управлении и свободном доступе к сертификату, связывающему субъекта (пользователя) с его открытым ключом. Синтаксис сертификатов формата Х.509 выражается с помощью особой нотации, так называемой абстрактной синтаксической нотации версии 1 (Abstract Syntax Notation One - ASN.1), которая была предложена комитетом разработчиков стандартов взаимодействия открытых систем OSI (Open System Interconnection) для использования с протоколами X.500. ASN.1 описывает синтаксис различных структур данных, вводя примитивные объекты и средства описания их комбинаций [2]. Форматы электронного сертификата и САС, предложенные X.509, фактически признаны стандартом и получили всеобщее распространение независимо от X.500. Как показало время, наиболее ценной в стандарте X.509 оказалась не сама процедура, а ее служебный элемент - структура сертификата, содержащая имя пользователя, криптографические ключи и сопутствующую информацию [6].

|Номер и название стандарта | Содержание стандарта |

|X.500 | Каталог: обзор концепций, моделей и услуг |

|X.509 | Каталог: структура аутентификации |

|X.509a | Проект изменений и дополнений для продления срока действия сертификатов (расширение версии 3) |

|X.208 (ISO/IEC 8825).

Abstract Syntax Notation (ASN.1).

| Абстрактная синтаксическая нотация |

|X.209 | Основные правила кодирования для ASN.1 |

|ISO/IEC 8824.

Object Identifiers (OIDs).

| Идентификаторы объектов |

|ISO/IEC 9594/8.

Directory Services (X.509).

| Сервисы каталога (X.509) |

Таблица 15.1.I группа стандартов.

Стандарты второй группы (см. табл. 15.2) разработаны основным центром по выпуску согласованных стандартов в области PKI - рабочей группой организации IETF, известной как группа PKIX (от сокращения PKI for X.509 certificates) [10]. Документы PKIX определяют политику применения сертификатов и структуру регламента УЦ, форматы, алгоритмы и идентификаторы сертификата и САС X.509, схему поддержки PKIX в среде LDAP v2, форматы атрибутных сертификатов и сертификатов ограниченного пользования, описывают протоколы статуса сертификатов, запроса на сертификацию, проставления метки времени, эксплуатационные протоколы PKI.

Третью группу образуют стандарты криптографии с открытыми ключами PKCS (Public Key Cryptography Standards), разработанные компанией RSA Security Inc. [102] совместно с неофициальным консорциумом, в состав которого входили компании Apple, Microsoft, DEC, Lotus, Sun и MIT. Документы PKCS признаны симпозиумом разработчиков стандартов взаимодействия открытых систем методом реализации стандартов OSI (Open System Interconnection). Стандарты PKCS (см. табл. 15.3) обеспечивают поддержку криптографических процессов при выполнении защищенного шифрованием информационного обмена между субъектами. Стандарты PKCS ориентированы на двоичные и ASCII-данные и совместимы со стандартом ITU-T X.509. В PKCS входят алгоритмически зависимые и независимые реализации стандартов [217]. Многие из них опираются на систему шифрования с открытыми ключами RSA, названную по инициалам авторов Ривеста, Шамира и Адльмана, метод эллиптических кривых и метод согласования ключей Диффи-Хэллмана, подробно описанные в трех соответствующих криптографических стандартах.

|Номер и название стандарта | Содержание стандарта |

|

RFC 2510.

Certificate Management Protocols (CMP).

| Инфраструктура открытых ключей Интернет X.509: протоколы управления сертификатами |

|

RFC 2511.

Certificate Request Protocol.

| Протокол запроса на сертификат |

|

RFC 2527.

Certificate Policy and Certification.

Practices Framework.

| Политика применения сертификатов и структура регламента |

|

RFC 2559.

LDAP V2 Operational Protocols.

| Эксплуатационные протоколы инфраструктуры открытых ключей |

|

RFC 2560.

Online Certificate Status Protocol (OCSP).

| Онлайновый протокол статуса сертификата |

|

RFC 2585.

HTTP/FTP Operations.

| Применение протоколов HTTP/FTP для получения сертификатов и САС и репозитория PKI |

|

RFC 2587.

LDAP V2 Schema.

| Схема поддержки PKIX в среде LDAP v2 |

|

RFC 2797.

Certificate Management Messages over.

CMS (CMC).

| Протокол управления сертификатами на базе сообщений управления сертификатами |

|

RFC 2875.

Diffie-Hellman Proof-of-Possession.

(POP) Algorithms.

| Алгоритмы Диффи-Хэлмана доказывания владения |

|

RFC 3029.

Data Validation and Certification.

Server Protocols.

| Протоколы сервера сертификации и проверки достоверности данных |

|

RFC 3039.

Qualified Certificates Profile.

| Формат сертификата ограниченного пользования |

|

RFC 3161.

Time-Stamp Protocol (TSP).

| Протокол меток времени |

|

RFC 3279 (бывший RFC 2528).

Algorithms and Identifiers for the.

Internet X.509 Public Key.

Infrastructure Certificate and.

Certificate Revocation List (CRL) Profile.

| Алгоритмы и идентификаторы для профилей сертификатов и САС PKIX |

|

RFC 3280 (бывший RFC 2459).

Certificate & CRL Profile.

| Форматы сертификата и списка аннулированных сертификатов X.509 |

|

RFC 3281.

An Internet Attribute Certificate.

Profile for Authorization.

| Формат атрибутного сертификата для авторизации |

Таблица 15.2.II группа стандартов.

|Номер и название стандарта | Содержание стандарта |

|

PKCS#1.

RSA Cryptography.

| Механизмы шифрования и подписания данных методом RSA.

Примечание:Стандарты PKCS #2 and PKCS #4 были объединены в PKCS #1.

|

|

PKCS #3.

Diffie-Hellman Key Agreement.

| Согласование ключей методом Диффи-Хеллмана |

|

PKCS #5.

Password-Based Cryptography.

| Шифрование секретным ключом, созданным на основе пароля |

|

PKCS #6.

Extended-Certificate Syntax.

| Синтаксис расширенного сертификата |

|

PKCS#7.

Cryptographic Message Syntax.

| Синтаксис криптографических сообщений |

|

PKCS #8.

Private-Key Information Syntax.

| Синтаксис данных секретного ключа |

|

PKCS #9.

Selected Attribute Types.

| Особые типы атрибутов для использования в других PKCS-стандартах |

|

PKCS#10 (RFC2314).

Certification Request Syntax.

| Стандарт синтаксиса запроса на сертификацию |

|

PKCS#11.

Cryptographic Token Interface (Cryptoki).

| Прикладной программный интерфейс Cryptoki для криптографических устройств типа смарт-карт и карт PCMCIA |

|

PKCS #12.

Personal Information Exchange Syntax.

| Синтаксис обмена персональными данными пользователя (секретными ключами, различными тайнами и т.п.) |

|

PKCS #13.

Elliptic Curve Cryptography.

| Механизмы шифрования и подписания данных методом эллиптических кривых |

|

PKCS #15.

Cryptographic Token Information Format.

| Формат данных, хранящихся на криптографических токенах (является дополнением к PKCS #11) |

Таблица 15.3.III группа стандартов.

Кроме того, стандарты PKCS определяют алгоритмически независимый синтаксис криптографических сообщений, данных секретного ключа, запросов на сертификацию, расширенных сертификатов, обмена персональными данными пользователя, что позволяет реализовать любой криптографический алгоритм в соответствии со стандартным синтаксисом и обеспечить взаимодействие самых разных приложений. Большинство стандартов, использующих криптографию, разработано с учетом применения PKI.

В четвертую группу объединены дополнительные связанные с PKI стандарты LDAP, S/MIME, S/HTTP, TLS, IPsec, DNS и SET (см. табл. 15.4). Стандарты LDAP описывают упрощенный протокол доступа, позволяющий вводить, удалять, изменять и извлекать информацию, которая содержится в каталогах X.500. В настоящее время LDAP является стандартным методом доступа к информации сетевых каталогов и играет важную роль во множестве продуктов, таких как системы аутентификации, PKI, приложения электронной почты и электронной коммерции.

Стандарты S/MIME (Secure/Multipurpose Internet Mail Extensions) предназначены для обеспечения защищенного обмена сообщениями в Интернете. Протокол защищенной электронной почты S/MIME базируется на технологии шифрования и цифровой подписи, разработанной компанией RSA Security Inc., и используется для предупреждения возможного перехвата или подделки почтовых сообщений [209]. Семейство стандартов S/MIME описывает синтаксис криптографических сообщений, управление сертификатами в среде S/MIME, процедуры и атрибуты дополнительных сервисов безопасности для почтовых приложений, к которым относятся заверенные цифровой подписью уведомления о приеме сообщений, метки безопасности и защищенные списки рассылки электронной почты.

К стандартам S/HTTP и TLS относятся документы, определяющие защищенный протокол передачи гипертекста HTTP и его расширения, протокол безопасности транспортного уровня TLS, его модификацию и использование в среде HTTP. TLS - открытый стандарт, разработанный на базе протокола защищенного обмена информацией между клиентом и сервером SSL (Secure Sockets Layer) в качестве его замены для защиты коммуникаций в Интернете. Протокол TLS обеспечивает конфиденциальность и целостность данных при коммуникации двух приложений и позволяет приложениям "клиент-сервер" взаимодействовать защищенным способом, предотвращающим перехват информации и подделку сообщений. Для взаимной аутентификации перед началом информационного взаимодействия приложениями используется технология PKI.

|Номер и название стандарта | Содержание стандарта |

|LDAP |

RFC 1777: Lightweight Directory Access.

Protocol.

| Упрощенный протокол доступа к каталогу |

|

RFC 1823: The LDAP Application Program.

Interface.

| Интерфейс прикладного программирования протокола LDAP |

|

RFC 2251: Lightweight Directory Access.

Protocol (v3).

| Упрощенный протокол доступа к каталогу (версия 3) |

|

RFC 2252: Lightweight Directory Access.

Protocol (v3): Attribute definition.

| Описание атрибутов протокола LDAP (версия 3) |

|

RFC 2253: Lightweight Directory Access.

LDAP.

Protocol (v3): UTF-8 String.

Representation of Distinguished Names.

| Представление отличительных имен в протоколе LDAP (версия 3) |

|

RFC 2254: Lightweight Directory Access.

Protocol (v3) The String.

Representation of LDAP Search Filters.

| Строковое представление фильтров поиска в протоколе LDAP (версия 3) |

|

RFC 2255: Lightweight Directory Access.

Protocol (v3) The LDAP URL Format.

| URL-формат протокола LDAP (версия 3) |

|S/MIME |

RFC 2311.

S/MIME Version 2 Message Specification.

| Спецификация сообщений S/MIME версии 2 |

|

RFC 2312.

S/MIMEv2 Certificate Handling.

| Управление сертификатами S/MIME версии 2 |

|

RFC 2630.

Cryptographic Message Syntax (CMS).

| Синтаксис криптографических сообщений |

|

RFC 2632.

S/MIME V3 Certificate Handling.

| Управление сертификатами S/MIME версии 3 |

|

RFC 2633.

S/MIME V3 Message Specification.

| Спецификация сообщений S/MIME версии 3 |

|

S/MIMERFC 2634.

Enhanced Security Services for S/MIME.

| Сервисы безопасности для S/MIME |

|

RFC 2785.

Methods for Avoiding the "Small-

Subgroup" Attacks on the Diffie-Hellman.

Key Agreement Method for S/MIME.

| Методы отражения атак на основе метода согласования ключей Диффи-Хэллмана для S/MIME |

|

RFC 3369 S/MIME Cryptographic Message.

Syntax.

| Синтаксис криптографических сообщений в S/MIME |

|S/HTTP TLS |

RFC 2246.

TLS Protocol Version 1.0.

| Протокол безопасности транспортного уровня TLS версии 1 |

|

RFC 2659.

Security Extensions For HTML.

| Расширения безопасности для протокола передачи гипертекста HTTP |

|

RFC 2660.

S/HTTP TLS.

The Secure HyperText Transfer Protocol.

| Защищенный протокол HTTP |

|

RFC 2817.

Upgrading to TLS Within HTTP.

| Модификация протокола TLS в среде HTTP |

|

RFC 2818.

HTTP Over TLS.

| Использование протокола TLS для защищенных HTTP-соединений через Интернет |

|IPsec |

RFC 2401.

Security Architecture for the Internet.

Protocol.

| Архитектура безопасности Интернет-протокола |

|

RFC 2402.

IP Authentication Header.

| Протокол аутентифицирующего заголовка |

|

IPsecRFC 2406.

IP Encapsulating Security Payload (ESP).

| Протокол инкапсулирующей защиты содержимого IP-пакетов |

|

RFC 2408.

Internet Security Association and Key.

Management Protocol (ISAKMP).

| Интернет-протокол управления ключами и контекстами безопасности |

|DNS |

RFC 2137.

Secure Domain Name System Dynamic Update.

| Динамическое обновление защищенной системы доменных имен |

|

RFC 2535.

Domain Name System Security Extensions.

| Расширения системы доменных имен |

|

RFC 2536.

DSA KEYs and SIGs in the Domain Name.

System.

| DSA-ключи и подписи в системе доменных имен |

|

RFC 2537.

RSA/MD5 KEYs and SIGs in the Domain.

Name System.

| RSA/MD5-ключи и подписи в системе доменных имен |

|

DNSRFC 2538.

Storing Certificates in the Domain.

Name System.

| Хранение сертификатов в системе доменных имен |

|

RFC 2539.

Storage of Diffie-Hellman Keys in the.

Domain Name System.

| Хранение ключей Диффи-Хэллмана в системе доменных имен |

|

RFC 2540.

Detached Domain Name System Information.

| Отделенная информация системы доменных имен |

|

RFC 2541.

DNS Security Operational Considerations.

| Операционные требования безопасности службы доменных имен |

|SET |

Secure Electronic Transaction.

Specification The Business Description.

| Защищенные электронные транзакции. Спецификация: Описание бизнеса |

|

Secure Electronic Transaction.

The Specification Programmer's Guide.

SET.

| Защищенные электронные транзакции. Спецификация: Руководство программиста |

|

Secure Electronic Transaction.

Specification Formal Protocol Definition.

| Защищенные электронные транзакции. Спецификация: Описание формального протокола |

Таблица 15.4.IV группа стандартов.

Инфраструктуры открытых ключей.

Рис. 15.1.  Взаимосвязь стандартов в области PKI.

Стандарты семейства IPsec описывают архитектуру безопасности Интернет-протоколов (IP), регламентируют контроль целостности на уровне IP-пакетов, аутентификацию источника данных и защиту от воспроизведения ранее посланных IP-пакетов, обеспечение конфиденциальности при помощи шифрования содержимого IP-пакетов, а также частичную защиту от анализа трафика путем применения туннельного режима [216]. Документы RFC, относящиеся к IPsec, содержат описания протокола аутентифицирующего заголовка, протокола инкапсулирующей защиты содержимого IP-пакетов и протокола управления ключами и контекстами безопасности. Стандарты IPsec обеспечивают конфиденциальность, целостность и достоверность данных, передаваемых через открытые IP-сети.

Стандарты DNS определяют механизмы, обеспечивающие безопасность данных инфраструктуры системы доменных имен DNS. Документы описывают операционные требования безопасности системы, методы хранения сертификатов и ключей Диффи-Хэллмана, динамическое обновление защищенной системы DNS, механизм защиты передаваемых данных с помощью алгоритма MD5, DSA и RSA-ключей и цифровых подписей. Для обеспечения достоверной передачи DNS-данных в масштабе Интернета в систему DNS вводятся расширения DNSSEC, задаваемые соответствующим стандартом.

Спецификация SET предлагает инфраструктуру для защиты от подделок платежных карт, используемых для транзакций электронной коммерции в Интернете, описывает систему аутентификации участников расчетов, которая базируется на PKI [2]. Принципы SET излагаются в трех книгах, содержащих сведения о правилах ведения бизнеса на базе защищенных электронных транзакций, руководство программиста и формальное описание протокола SET. Рис. 15.1 иллюстрирует взаимосвязь стандартов в области PKI [10].

Итак, базой для разработки стандартов в области PKI стали стандарты серии X.500 (хотя не все их наименования начинаются с X.5xx) Международного союза электросвязи (ITU), предложившие стандартную структуру баз данных, записи в которых содержали информацию о пользователях [3]. Стандарт X.509 ITU-T является фундаментальным стандартом, который лежит в основе всех остальных, используемых в PKI. Однако X.509 ITU-T не описывает полностью технологию PKI. В целях применения стандартов X.509 в повседневной практике комитеты по стандартизации, пользователи, поставщики программных продуктов и сервисов PKI обращаются к семейству стандартов PKIX.